How to configure static routing on two cisco routers connected with different type of networks.

When we connect different networks we have to use routers in between the networks. and if we have to make the networks work/connect which are not connected directly to the router we have to configure routing on the router. routing are of two type :-

  1. static routing: In stating routing we have to give information and path of each network manually.
  2. dynamic routing: dynamic routing is the routing in which we have to give the information of the network which  is directly connected and the router itself gets the further information.

Today we connects three networks using static routing.the networks connected are given as follows:-static routing

Firstly, assign ip to both the routes

Router0

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface fa0/0

Router(config-if)#ip address 1.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

exit

Router(config)#interface fa0/1

Router(config-if)#ip address 2.0.0.1 255.0.0.0

Router(config-if)#no shut

Router1

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fa0/1
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
exit
Router(config)#interface fa0/0
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shut

Also assign ip to the computers.

Now we have to configure static routing on computer.To configure static routing go to configure mode in router and type command

Router0

Router(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

Router1

Router(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

Here first 3.0.0.0/1.0.0.0 are the network address of the network which are not directly connected to routers, 255.0.0.0 is the subnet mask of the network and 2.0.0.2/2.0.0.1 is the getway ip, of the port of other router from which the network is going out to connect to another network.

After configure routing you can check the network by pinging or by send message in cisco packet tracerstatic routing

One thought on “How to configure static routing on two cisco routers connected with different type of networks.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s