Configure your router to work as a DHCP server.

DHCP server is used to assigning IP to the computer automatically. But as you know that buying a server is costly.To reduce that cost we can configure our router to work as DHCP server. after configuring router as dhcp server we don’t need any dhcp serer to assigning ip to the computer. the router will  do that work of assigning ip. But you should not use this method to work in large no. of networks because just in case if the router fails  your whole networks will fail to work.so,for a large network you should use a dhcp server. I would prefer to use this method only in small networks.

For practice lets take a sample problem.

router as dhcp server

Firstly we assign ip to the router ports and give host name to the router.

Assigning IP

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname Router1

Router1(config)#int fa0/0

Router1(config-if)#ip address 1.0.0.1 255.0.0.0

Router1(config-if)#no shut

Router1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

exit

Router1(config)#int fa0/1

Router1(config-if)#ip address 2.0.0.1 255.0.0.0

Router1(config-if)#no shut

Now create a DHCP pool on router by following commands.

Creating Pool

Router1(config)#ip dhcp pool pool1

Router1(dhcp-config)#network 1.0.0.0 255.0.0.0

Router1(dhcp-config)#default-router 1.0.0.1

Router1(dhcp-config)#exit

Router1(config)#ip dhcp pool pool2

Router1(dhcp-config)#network 2.0.0.0 255.0.0.0

Router1(dhcp-config)#default-router 2.0.0.1

Router1(dhcp-config)#exit

*here pool1/pool2 is the name of that pool to identify the network, and default-router is the ip of the port which is connected to that network.

Now you can assign ip to the computer b DHCP setting and it will take the ip automatically.

 

One thought on “Configure your router to work as a DHCP server.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s