How to configure a single router as multiple DHCP server

This article is all about how to configure a single router as multiple DHCP servers. In the previous article, we learn about how to configure a router as a DHCP server in cisco packet tracer. Here in this tutorial, we configure a single router as multiple DHCP servers.

By using this method you can easily manage many of the networks by using a single router. You can also be able to provide IP address to all of your connected PCs in different networks without using a DHCP server (Machine). So, let’s start here how to configure a single router as multiple DHCP servers.

Here to understand this process we take a lab in cisco packet tracer and in this lab we take 1 router, and four PCs and configure them by using given below steps.

First of all, we add two extra ports in your router because your router only has 2 fast ethernet ports. But to perform this lab we required four ethernet ports. So, we add two ethernet ports on that router. After that connect all the PCs according to the figure is shown below.

multiple DHCP server on a router

Now, first of all, we set a hostname on the router using given below commands. Here we set hostname because by hostname we can easily identify a router. In companies, many of the routers will be used to connected different networks at that time hostname will be very useful in identifying a router. So, we set hostname on routers

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname Rahul

Now on port fa0/0

Use given below code on fa0/0 port on your router to assign IP address and create a DHCP pool on your router

Rahul(config)#int fa0/0

Rahul(config-if)#ip address 10.0.0.1 255.0.0.0

Rahul(config-if)#no shut

Rahul(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Rahul(config-if)#ip dhcp pool rahul

Rahul(dhcp-config)#network 10.0.0.0 255.0.0.0

Rahul(dhcp-config)#default-router 10.0.0.1

Rahul(dhcp-config)#exit

Now on port fa0/1

Rahul(config)#int fa0/1

Rahul(config-if)#ip address 40.0.0.1 255.0.0.0

Rahul(config-if)#no shut

Rahul(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Rahul(config-if)#ip dhcp pool dd

Rahul(dhcp-config)#network 40.0.0.0 255.0.0.0

Rahul(dhcp-config)#default-router 40.0.0.1

Rahul(dhcp-config)#exit

Now on port Eth0/0/0

Rahul(config)#int Eth0/0/0

Rahul(config-if)#ip address 30.0.0.1 255.0.0.0

Rahul(config-if)#no shut

Rahul(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

Rahul(config-if)#ip dhcp pool deepit

Rahul(dhcp-config)#network 30.0.0.0 255.0.0.0

Rahul(dhcp-config)#default-router 30.0.0.1

Rahul(dhcp-config)#exit

Now on port Eth0/1/0

Rahul(config)#int Eth0/1/0

Rahul(config-if)#ip address 20.0.0.1 255.0.0.0

Rahul(config-if)#no shut

Rahul(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1/0, changed state to up

Rahul(config-if)#ip dhcp pool hemendra

Rahul(dhcp-config)#network 20.0.0.0 255.0.0.0

Rahul(dhcp-config)#default-router 20.0.0.1

Rahul(dhcp-config)#exit

Rahul(config)#%DHCPD-4-PING_CONFLICT: DHCP address conflict: server pinged 10.0.0.1.

%DHCPD-4-PING_CONFLICT: DHCP address conflict: server pinged 20.0.0.1.

%DHCPD-4-PING_CONFLICT: DHCP address conflict: server pinged 30.0.0.1.

%DHCPD-4-PING_CONFLICT: DHCP address conflict: server pinged 40.0.0.1.

After that, your router will be able to provide IP address to the computers which are connected to the router directly. To take IP address on your connected PCs go to IP configuration menu and then change static to dynamic and for few seconds. Now you saw that your computer will take IP automatically using the router without using a DHCP server.

Now after that  troubleshoot your routing using troubleshooting command on your router use given below command to verify your routing

Rahul#show ip dhcp binding

IP address Client-ID/ Lease expiration Type

Hardware address

10.0.0.2 0060.7027.8897 — Automatic

40.0.0.2 0000.0C56.1847 — Automatic

30.0.0.2 00E0.A3B5.6B0D — Automatic

20.0.0.2 000C.CF2B.0013 — Automatic

If you have any queries regarding this feel free to ask through using the comment section.
To saw this full process in video format click on given below link

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s