RIP version 1 routing configuration on cisco routers (cisco packet tracer)

This article is all about how to configure RIP (routing information protocol) version 1 on the cisco routers. It is the oldest distance-vector routing protocols which employ the hop count as a routing metric.The maximum numbers of hops allowed for RIP are 15, which limits the size of the network that RIP can support. RIP routing is applicable only on up to 15 routers. RIP routing configuration is much easier than static routing but static routing is more secure than RIP routing.

So always we preferred static routing instead of RIP routing in a small network. Generally, in small companies (which have less than 15 routers because RIP routing only supports 15 routers), we always use RIP routing because it is easier in configuration. So now here we learn about how to configure RIP version 1 routing on routers using a lab in cisco packet tracer. 

Here in this lab we take three routers and three PCs perform routing information protocol configuration lab. In this article we also learn about how to troubleshoot youur RIP routing on your router.

how to configure RIPv1 routing on cisco routers

Now first of all we assign IP address to all the interfaces of router and also set a hostname on each router using given below command.

For router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/1

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R1(config-if)#exit

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

 

For router R2

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface FastEthernet0/1

R2(config-if)#ip address 4.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R2(config-if)#exit

R2(config)#interface Ethernet0/0/0

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

R2(config-if)#exit

 

For router R3

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R3

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 4.0.0.2 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#interface FastEthernet0/1

R3(config-if)#ip address 5.0.0.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R3(config-if)#exit

Now IP address will be assigned on every interface of router now we configure RIP version 1 routing on each router.

Now for configure RIP routing on each router use given below commands

For router R1

R3(config)#router rip

R3(config-router)#version 1

 

R3(config-router)#network 5.0.0.0

R3(config-router)#network 4.0.0.0

R3(config-router)#exit

 

For router R2

R2(config)#router rip

R2(config-router)#version 1

R2(config-router)#network 2.0.0.0

R2(config-router)#network 3.0.0.0

R2(config-router)#network 4.0.0.0

R2(config-router)#exit

 

For router R3

R1(config)#router rip

R1(config-router)#version 1

R1(config-router)#network 1.0.0.0

R1(config-router)#network 2.0.0.0

R1(config-router)#exit

Now RIPv1 routing will be configured on all the routers. Now after that assign IP address to all the PCs according to their networks and ping these PCs with each other and check they are communicate with each other or not.

 

Now we run troubleshoot commands on router R1 and verify your routing

R1#show ip protocols

Routing Protocol is “rip”

Sending updates every 30 seconds, next due in 9 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Redistributing: rip

Default version control: send version 1, receive 1

Interface Send Recv Triggered RIP Key-chain

FastEthernet0/1 1 1

FastEthernet0/0 1 1

Automatic network summarization is in effect

Maximum path: 4

Routing for Networks:

1.0.0.0

2.0.0.0

Passive Interface(s):

Routing Information Sources:

Gateway Distance Last Update

2.0.0.2 120 00:00:20

Distance: (default is 120)

 

R1#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, FastEthernet0/1

C 2.0.0.0/8 is directly connected, FastEthernet0/0

R 3.0.0.0/8 [120/1] via 2.0.0.2, 00:00:18, FastEthernet0/0

R 4.0.0.0/8 [120/1] via 2.0.0.2, 00:00:18, FastEthernet0/0

R 5.0.0.0/8 [120/2] via 2.0.0.2, 00:00:18, FastEthernet0/0

 

R1#show ip rip database

1.0.0.0/8 auto-summary

1.0.0.0/8 directly connected, FastEthernet0/1

2.0.0.0/8 auto-summary

2.0.0.0/8 directly connected, FastEthernet0/0

3.0.0.0/8 auto-summary

3.0.0.0/8

[1] via 2.0.0.2, 00:00:19, FastEthernet0/0

4.0.0.0/8 auto-summary

4.0.0.0/8

[1] via 2.0.0.2, 00:00:19, FastEthernet0/0

5.0.0.0/8 auto-summary

5.0.0.0/8

[2] via 2.0.0.2, 00:00:19, FastEthernet0/0

 

R1#show ip route rip

R 3.0.0.0/8 [120/1] via 2.0.0.2, 00:00:02, FastEthernet0/0

R 4.0.0.0/8 [120/1] via 2.0.0.2, 00:00:02, FastEthernet0/0

R 5.0.0.0/8 [120/2] via 2.0.0.2, 00:00:02, FastEthernet0/0

 

R1#show ip interface brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 2.0.0.1 YES manual up up

FastEthernet0/1 1.0.0.1 YES manual up up

Vlan1 unassigned YES unset administratively down down

 

R1#show protocols

Global values:

Internet Protocol routing is enabled

FastEthernet0/0 is up, line protocol is up

Internet address is 2.0.0.1/8

FastEthernet0/1 is up, line protocol is up

Internet address is 1.0.0.1/8

Vlan1 is administratively down, line protocol is down

If you have any queries regarding rip routing configuration simply solved out your queries through using comment section.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s