How to configure RIP version 1 routing on routers having serial ports

This article is all about how to configure RIP version 1 routing on routers having serial ports. In the previous lab, we learn RIP configuration on routers having Fast ethernet port now we use serial ports instead of ethernet ports. This is little bit difference because in this type of configuration we always set clock rate on the DCE (Data Communication Equipment) port of the router. Because clock rate is used to set the bandwidth of your DTE (Data terminal equipment) port of the router.

This type of configuration mainly used in Internet service provider (ISP) companies who provide the internet to users. These  ISP companies always use serial ports in their routers and set bandwidth on DCE port of the router according to the occupied plan of the user. So now let’s start here configuration RIPv1 routing on the routers having serial ports.

Now here we take a lab in cisco packet tracer to understand RIP version 1 routing along with serial ports.

configure RIP routing version 1

In this lab, we take 3 computers, 3 routers, and DCE cables to perform and understand this RIP routing version 1 perfectly. At the end of this lab, we also run troubleshooting commands to confirm and verify our RIP version 1 routing with ease.

Now, first of all, we assign the IP address to all the interfaces of the router and use no shut command to up all the ports of the routers.

For router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

 

Router(config)#hostname R1

R1(config)#int fa0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shut

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R1(config-if)#exit

 

For router R2

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/1

R2(config-if)#ip address 4.0.0.1 255.0.0.0

R2(config-if)#clock rate 64000

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R2(config-if)#exit

 

For router R3

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R3

R3(config)#interface Serial0/0/0

R3(config-if)#ip address 4.0.0.2 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R3(config-if)#exit

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 5.0.0.1 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

Now we saw that IP address will be assigned on all the interfaces of the router. Now after that configure RIP routing on all the routers using given below codes.

RIP routing configuration on cisco routers

For router R1

R1>enable

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#router rip

R1(config-router)#version 1

R1(config-router)#network 1.0.0.0

R1(config-router)#network 2.0.0.0

R1(config-router)#exit

 

For router R2

R2>enable

R2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#router rip

R2(config-router)#version 1

R2(config-router)#network 2.0.0.0

R2(config-router)#network 3.0.0.0

R2(config-router)#network 4.0.0.0

R2(config-router)#exit

 

For router R3 

R3>enable

R3#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#router rip

R3(config-router)#version 1

R3(config-router)#network 4.0.0.0

R3(config-router)#network 5.0.0.0

R3(config-router)#exit

Now we saw that RIP routing is configured on all the routers. Now assign IP address on all the PCs and check that they are communicating with each other or not.

Now to verify your RIP routing on any of the given router use given below code Like here we troubleshoot router R1

Troubleshooting command on router R1

R1#show ip protocols

Routing Protocol is “rip

Sending updates every 30 seconds, next due in 1 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Redistributing: rip

Default version control: send version 1, receive 1

Interface Send Recv Triggered RIP Key-chain

FastEthernet0/0 1 1

Serial0/0/0 1 1

Automatic network summarization is in effect

Maximum path: 4

Routing for Networks:

1.0.0.0

2.0.0.0

Passive Interface(s):

Routing Information Sources:

Gateway Distance Last Update

2.0.0.2 120 00:00:09

Distance: (default is 120)

 

R1#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, FastEthernet0/0

C 2.0.0.0/8 is directly connected, Serial0/0/0

R 3.0.0.0/8 [120/1] via 2.0.0.2, 00:00:11, Serial0/0/0

R 4.0.0.0/8 [120/1] via 2.0.0.2, 00:00:11, Serial0/0/0

R 5.0.0.0/8 [120/2] via 2.0.0.2, 00:00:11, Serial0/0/0

 

R1#show ip rip database

1.0.0.0/8 auto-summary

1.0.0.0/8 directly connected, FastEthernet0/0

2.0.0.0/8 auto-summary

2.0.0.0/8 directly connected, Serial0/0/0

3.0.0.0/8 auto-summary

3.0.0.0/8

[1] via 2.0.0.2, 00:00:05, Serial0/0/0

4.0.0.0/8 auto-summary

4.0.0.0/8

[1] via 2.0.0.2, 00:00:05, Serial0/0/0

5.0.0.0/8 auto-summary

5.0.0.0/8

[2] via 2.0.0.2, 00:00:05, Serial0/0/0

 

R1#show ip route rip

R 3.0.0.0/8 [120/1] via 2.0.0.2, 00:00:05, Serial0/0/0

R 4.0.0.0/8 [120/1] via 2.0.0.2, 00:00:05, Serial0/0/0

R 5.0.0.0/8 [120/2] via 2.0.0.2, 00:00:05, Serial0/0/0

 

R1#show ip interface brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 1.0.0.1 YES manual up up

FastEthernet0/1 unassigned YES unset administratively down down

Serial0/0/0 2.0.0.1 YES manual up up

Serial0/0/1 unassigned YES unset administratively down down

Serial0/1/0 unassigned YES unset administratively down down

Serial0/1/1 unassigned YES unset administratively down down

Vlan1 unassigned YES unset administratively down down

 

R1#show protocols

Global values:

Internet Protocol routing is enabled

FastEthernet0/0 is up, line protocol is up

Internet address is 1.0.0.1/8

FastEthernet0/1 is administratively down, line protocol is down

Serial0/0/0 is up, line protocol is up

Internet address is 2.0.0.1/8

Serial0/0/1 is administratively down, line protocol is down

Serial0/1/0 is administratively down, line protocol is down

Serial0/1/1 is administratively down, line protocol is down

Vlan1 is administratively down, line protocol is down

 

If you have any queries regarding RIP version 1 configuration feel free to ask through the comment section.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s