How to configure EIGRP routing on cisco routers having serial ports

This article is all about how to configure EIGRP (Enhance Interior Gateway Routing Protocol) routing on cisco routers having serial ports. In the previous article, we will learn about how to configure RIP version 1 routing on cisco routers having serial ports. But we know that RIP routing is used only in small companies who having less than fifteen routers. Because RIP routing only works up to fifteen routers so generally, we use RIP routing in small companies. If a company have more than fifteen routers in it then RIP routing is not much useful to us. In that case, we use EIGRP routing protocol to configure routers in a network.

Now to understand EIGRP routing in depth we take a simple lab in cisco packet tracer. In this lab, we take two routers having serial ports and take two PCs by which we easily confirm that our EIGRP configuration works perfectly on routers or not. So let’s start here

configure EIGRP routing on cisco routers

 

We take this whole lab in two successive parts to understand EIGRP protocol with ease. In the first part, we assign an IP address to all the interfaces of routers and up all the routers using no shut command. In the second part, we configure EIGRP routing on all the routers and also assign the IP address to all the PCs according to their networks and check whether they are communicating or not. If they communicate perfectly with each other that means our EIGRP routing is successfully configured on routers. So let’s start here

First part: – Assign IP address to all the interfaces of routers

For router R1

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R1(config-if)#exit

 

 

For router R2

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

 

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

R2(config)#

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

IP address will be assigned to all the interfaces of the routers and all the ports are up. Now we configure EIGRP routing on both the routers in the second part.

 

Second Part: – EIGRP configuration on routers

For router R1 

use given below codes to configure EIGRP on your router R1

R1(config)#route eigrp 1

R1(config-router)#network 1.0.0.0

R1(config-router)#network 2.0.0.0

R1(config-router)#

%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 2.0.0.2 (Serial0/0/0) is up: new adjacency

R1(config-router)#exit

 

For router R2

Now use given below codes to configure EIGRP on router R2

 

R2(config)#router eigrp 1

R2(config-router)#network 2.0.0.0

R2(config-router)#network 3.0.0.1

R2(config-router)#exit

Now after configuring EIGRP routing on both the routers assign the IP address to both the PCs and check whether they are communicating with each other or not using the ping command.

Like I choose PC0 to check communication by using the ping command. So now I am going to the command prompt of PC0 and use given below code to check

Packet Tracer PC Command Line 1.0

PC>ping 3.0.0.2

Pinging 3.0.0.2 with 32 bytes of data:

Request timed out.

Reply from 3.0.0.2: bytes=32 time=19ms TTL=126

Reply from 3.0.0.2: bytes=32 time=3ms TTL=126

Reply from 3.0.0.2: bytes=32 time=3ms TTL=126

Ping statistics for 3.0.0.2:

Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),

Approximate round trip times in milli-seconds:

Minimum = 3ms, Maximum = 19ms, Average = 8ms

If you get this type of result that means your EIGRP routing will be placed successfully on your routers. If you have any queries regarding this feel free to ask through using the comment section and also give feedback through the comment section.

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s