How to configure null routing on cisco routers in cisco packet tracer

This article is all about how to configure null 0 routing on cisco routers in cisco packet tracer. In other words, we also can say that black hole routing configuration on cisco routers. Null routing (blackhole route) is a network route that goes nowhere. Matching packets are dropped (ignored) rather than forwarded, acting as a kind of very limited firewall.

The acting of using null routes is often called blackhole filtering. In the other words, we can say that null route or blackhole route is a route which diverts the packet in the black hole from where it never come back again. Null routing is generally used in companies to drop some specific network or stop the DDOS attack. you can filter or drop packet even by using ACL but the Null route is best because access list required more CPU overhead. So let’s start here how to configure null routing on cisco in cisco packet tracer.

Now we take a lab in cisco packet tracer to understand this tutorial easily. In this lab, we take four routers and four computers.

configure null routing on cisco routers

Here in this lab, we going to block packets generated from router R1 1.0.0.0 network for 7.0.0.0 network.

First of all, we provide IP address to all the interfaces of routers and up all the routers using no shut command.

For router R1 

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 1.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial0/0/0

Router(config-if)#ip address 2.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

Router(config-if)#exit

Router(config)#interface Serial0/0/1

Router(config-if)#ip address 3.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

Router(config-if)#exit

 

 

For router R2

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 4.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial0/0/0

Router(config-if)#ip address 2.0.0.2 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial0/0/1

Router(config-if)#ip address 5.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

Router(config-if)#exit

 

 

For router R3

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 8.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial0/0/0

Router(config-if)#ip address 3.0.0.2 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial0/0/1

Router(config-if)#ip address 6.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

Router(config-if)#exit

 

 

For router R4

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 7.0.0.1 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial0/0/0

Router(config-if)#ip address 5.0.0.2 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial0/0/1

Router(config-if)#ip address 6.0.0.2 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

Router(config-if)#exit

Now IP address will be provided on all the interfaces of the router and also up all the interfaces of the routers. Now provide IP address to all the PCs using the static method.

 

Now configure routing on all the routers using given below code

For router R1

 

Router(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2

Router(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.2

Router(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2

Router(config)#ip route 6.0.0.0 255.0.0.0 3.0.0.2

Router(config)#ip route 7.0.0.0 255.0.0.0 null0

 

For router R2

 

Router(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

Router(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.1

Router(config)#ip route 7.0.0.0 255.0.0.0 5.0.0.2

Router(config)#ip route 6.0.0.0 255.0.0.0 5.0.0.2

Router(config)#ip route 8.0.0.0 255.0.0.0 6.0.0.1

 

For router R3

Router(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

Router(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1

Router(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2

Router(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.2

Router(config)#ip route 7.0.0.0 255.0.0.0 6.0.0.2

 

For router R4

Router(config)#ip route 8.0.0.0 255.0.0.0 6.0.0.1

Router(config)#ip route 3.0.0.0 255.0.0.0 6.0.0.1

Router(config)#ip route 4.0.0.0 255.0.0.0 5.0.0.1

Router(config)#ip route 2.0.0.0 255.0.0.0 5.0.0.1

Router(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

Now after that use ping command to check that whether our Null routing is configured or not. So to this purpose we use two PCs which is directly conneted from router R1 and router R4.

Now we give into command prompt of PC which is directly connected from R1 and then use given below command

Packet Tracer PC Command Line 1.0

PC>ping 7.0.0.2

Pinging 7.0.0.2 with 32 bytes of data:

Reply from 1.0.0.1: Destination host unreachable.

Reply from 1.0.0.1: Destination host unreachable.

Reply from 1.0.0.1: Destination host unreachable.

Reply from 1.0.0.1: Destination host unreachable.

Ping statistics for 7.0.0.2:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

If you have this type of result then your Null routing is configured correctly otherwise you do something wrong. If you have any queries regarding this solved out through the comment section and also provide feedback to us because your feedback is valuable for us.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s