Learn how to configure PAP on cisco routers

In this article, we will discuss how to configure PAP {Password Authentication Protocol} on cisco routers and uses of PAP in companies. We know that there are two authentication protocols used on routers one is PAP and other is CHAP. Now the first thing comes in your mind is what the hell is this PAP is an authentication method that can be used over point to point link.

PAP is a simple protocol but it is less secure than CHAP authentication protocol. PAP authentication method is used for verifying a routers identity when it was connecting into your router option for authentication including CHAP and PAP. So let’s start here how to configure PAP on a router.

Now to understand this configuration we take a lab in cisco packet tracer student.

PAP configuration on cisco routers

In this lab we take two routers and two PCs only, first of all, we assign IP address on all the interfaces of routers and use no shut command for up all the ports instantly. After that, we configure PAP on it and then we use the ping command to check whether they are communicating with each other or not.

Now we start configuration on both the routers 

For router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R1(config-if)#exit

 

Now to check your routers interface whether it is HDLC or not use given below code on R1 Generally all the routers are configured HDLC by default

R1>enable

R1#show interface se0/0/0

Serial0/0/0 is down, line protocol is down (disabled)

Hardware is HD64570

Internet address is 2.0.0.1/8

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

If here HDLC is displayed on your routers interface then your router is by default work on HDLC.

 

Now we configure PAP on router R1 using given below command and also verify our routing on R1 using troubleshooting command

R1>enable

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#username R2 password rahul

R1(config)#interface serial0/0/0

R1(config-if)#encapsulation ppp

R1(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down

R1(config-if)#ppp authentication pap

R1(config-if)#ppp pap sent-username R1 password rahul

R1(config-if)#exit

R1(config)#exit

 

Now to check PAP configuration on router R1 use given below command

R1#show interface serial0/0/0

Serial0/0/0 is up, line protocol is down (disabled)

Hardware is HD64570

Internet address is 2.0.0.1/8

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set, keepalive set (10 sec)

If here PPP is displayed instead of HDLC on your router then your configuration take place successfully. Now go to router R2 and use given below command to configure router R2

 

For router R2

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

 

Now to check your routers interface whether it is HDLC or not use given below code on R2

R2>enable

R2#show interface se0/0/0

Serial0/0/0 is up, line protocol is up (connected)

Hardware is HD64570

Internet address is 2.0.0.2/8

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

If here HDLC is displayed on your routers interface then your router is by default work on HDLC.

 

Now we configure PAP on router R1 using given below command and also verify our routing on R2 using troubleshooting command

R2>enable

R2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#username R1 password rahul

R2(config)#interface serial0/0/0

R2(config-if)#encapsulation ppp

R2(config-if)#ppp authentication pap

R2(config-if)#ppp pap sent-username R2 password rahul

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

R2(config)#exit

 

Now to check PAP configuration on router R use given below command

R2#show interface serial0/0/0

Serial0/0/0 is up, line protocol is up (connected)

Hardware is HD64570

Internet address is 2.0.0.2/8

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set, keepalive set (10 sec)

If here PPP is displayed instead of HDLC on your router in troubleshooting command then your configuration take place successfully.

 

Now we use the ping command on both the routers to check whether they are properly communicate with each other or not. The results will be shown below for both the routers after using ping command

For router R1

R1(config)#do ping 2.0.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.0.0.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/17 ms

 

For router R2

R2(config)#do ping 2.0.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.0.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/15/45 ms

 

Now you can saw that in both the cases success rate is 100 percent that means these both routers are work properly and PAP configuration successfully takes place on both the routers. If you have any queries regarding this then feel free to ask using the comment section. We are here to help you.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s